Windows Vista - Setup and Applications

System Default Browser and Email applications

Notes MicroSoft has yet again changed the way you access default Web and Email applications. So for example if, within Thunderbird and Firefox , you have set them to be default you can still get IE popping up when clicking on an web link in a Thunderbird email.
Fix
  • Control Panel -> Internet Properties -> Programs Tab
    -> Set Programs -> Set Program Defaults
    Now in the Left window pick the program you want, like Thunderbird or Firefox, and look at Choose Defaults for this program (if you want to view or update individual actions or associations) - or - Set Program as default (You might want to review the associations later)

Mozilla Vista Bugs

Thunderbird observations

  • In 1.5.08 I have noticed that email web links randomly stop working from time time even after setting the System defaults
    • (lfolland - I get this too)
  • The default Mail application checkbox keeps clearing itself
    • (lfolland - I believe this is due to not being Administrator...)

SSH

  • After a clean install my SSH profile was under AppData\Roaming\SSH. It stayed this way for two weeks then just decided to change to Application Data\SSH. I had SSH open at the time with active profiles. Tried to open a new window - no profiles. Create a new profile and it ended up under the new path! Copy the AppData\Roaming\SSH to the new location - works again.

Symantec AV 10.1.5

  • Web links point to IE regardless of system defaults or settings

Cygwin

Notes 25 Jan 2007 - downloaded Cygwin setup.exe and pointed to www.mirror.cs/cygwin
  • Setup options install everything - installer stopped partway through the post install phase at 99%
  • Had to kill the shell processes with task manager
  • Next; Reran setup.exe (it jumped to the post install phase good!) and finished without error

Networking

  • (lfolland - what's this for?)
  • Disable Priority & VLAN in your network cards Advanced settings
    • Control Panel -> System Properties -> Device Manager -> Network Adaptors
      Open your network card -> Advanced -> Priority & VLAN = Disabled
  • Priority & VLAN:
    Priority & VLAN

Nero 7

  • Vista and Nero 7 - Wants to "upgrade" directX 10 to 9.0c
    They say it is ok but the quick launch tool does not quite work
  • I have tested making CD and DVD's from data files and burning ISO images as well as bootable images - all work fine
    Note I only installed the nero burning rom component for my tests)

Samba breaks Vista backup

Vista Breaks Samba Roaming Profiles

  • Older Windows XP and 2000 profiles are not compatible with Windows Vista. Vista profiles have the suffix .V2 attached to their path names if a profile path is specified for a user. At least for roaming domain user profiles.
  • Roaming profiles maintained on our SAMBA servers will not load on Vista because the SAMBA server will not provide ownership and permission information for the profile. This security feature can be disabled by updating the following registry value on the local Vista machine:
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System]
         "CompatibleRUPSecurity"=dword:00000001

It seems that simply adding that key will cause it to get clobbered at some point. MS documentation suggests that using gpedit.msc will do the trick instead.

Resources

Edit | Attach | Watch | Print version | History: r9 < r8 < r7 < r6 < r5 | Backlinks | Raw View | WYSIWYG | More topic actions
Topic revision: r9 - 2008-06-13 - MikePatterson
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2020 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback