-- MikeGore - 05 Jan 2006

Howto Upgrade to mozilla 1.7.12 and make Xprint work

  • Note Prior to upgrade you receive the following error trying to print
    Error message prior to update

Background

  • Find your active (most receint) prefs.js file
        ls -l ~/.mozilla/*/*.slt/prefs.js
        
  • The updated mozilla 1.7.12 also needs an updated user prefs.js file - this contains your Mozilla configuration

Update only your printer settings

  • Make sure you exit Mozilla first!
  • Find your active (most receint) prefs.js file
        ls -l ~/.mozilla/*/*.slt/prefs.js
        
  • Edit your prefs.js file and remove all lines that start with user_pref("printer
  • insert this file printer into your existing prefs.js file - updates printer config

Install with new prefs.js (lose old settings)

  • Make sure you exit Mozilla first!
  • To start with a newbrand new configuration use this file prefs.js to replace your existing prefs.js file

Verify Settings

Note* example uses lj_cs
  • Start mozilla 1.7.12 /software/mozilla-1.7.12/private/bin/mozilla &
  • Open Printer Menu
    Printer Menu
  • Open Printer Properties:
    Printer Properties
  • Update Printer Properties Command to as lpr -Plj_cs as below
    Printer Properties Command

Topic revision: r5 - 2006-11-30 - MikeGore
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback