Configuring Macintosh Systems To Work With The Web-Based FORE Financial System

The FORE Financial System requires "PDF Drill Downs". Out-of-the-box Macintosh systems require add-ons to the FORE system. If Firefox is your browser of choice, a specific version is required, 17 ESR, see below.

To check if drill downs are working, go to the Drill Down Test Page, provided by Dani Roloson of MFCF.

The following web browser and browser plugin combinations have been demonstrated to work on a Macintosh system with the FORE system.

  1. Firefox with PDF Browser Plugin
  2. Safari with PDF Browser Plugin
  3. Safari with AdobePDFViewer Plugin

The first two solutions use the PDF Browser Plugin from Schubert|it.

Obtaining PDF Browser Plugin

Note: PDF Browser Plugin 2.4.2 is the highest release that works correctly with the FORE system.

The .dmg installation file for PDF Browser Plugin 2.4.2 can be downloaded from Schubert|it or locally.

Once PDF Browser Plugin 2.4.2 is installed, it can be found on the system in the "/Library/Internet Plug-Ins/" directory (the file is PDF Browser Plugin.plugin).

Firefox with PDF Browser Plugin

Note: Versions of Firefox greater than 17, will not do the "drilldowns" for the FORE system, even with PDF Browser Plugin 2.4.2 configured with Firefox.

Firefox 17 was an ESR (Extended Support Release), but this ESR became out-of-date a short time after version 24 ESR came out. This means that Firefox 17 is no longer receiving security updates. Firefox 17 ESR can be downloaded from Mozilla or locally.

After, both Firefox 17 ESR and PDF Browser Plugin 2.4.2 are installed, the following changes are required in Firefox's configuration.

  • Go to the Tools menu and select Add-ons and disable the Adobe Acrobat NPAPI Plug-in.
  • Go to the Firefox menu and select Preferences. Go to the Applications tab. Change PDF settings to use PDF Browser Plugin 2.4.2.
Check the Firefox configuration with Check Firefox Information page and drill downs with Drill Down Test Page.

Safari with PDF Browser Plugin

Once the PDF Browser Plugin is installed, there should not be any additional configuration; the PDF Drill Downs should work in Safari.

Test the drill downs with Drill Down Test Page.

Safari solution - without involving the PDF Browser Plugin

Safari with AdobePDFViewer Plugin

Note: The AdobePDFViewer Plugin is included in Adobe Acrobat Reader not included with Acrobat Pro, therefore Acrobat Reader will need to be installed if it is not already there.

  • Install Acrobat Reader, if required.
  • Configure Safari to use AdobePDFViewer Plugin
    1. Click on the Safari menu and select Preferences
    2. Select the Security tab
    3. Check the "Allow Plug-ins" if it is not already checked
    4. Click on the "Manage Website Settings..." button
    5. If PDF Browser Plugin is installed, make sure it is set to "Block" The Plug-in components are listed in the left-portion of the pane.
    6. For "Adobe Reader" select "Always Allow" for uwaterloo.ca.
Once the AdobePDFViewer Plugin is installed, it can be found on the system in the "/Library/Internet Plug-Ins/" directory (the file is AdobePDFViewer.plugin).

Test the Safari setup with Drill Down Test Page.

-- StephenNickerson - 2014-09-23

Local copies of the installation files for PDF Browser Plugin 2.4.2 and Firefox 17 ESR

Topic attachments
I Attachment Action Size Date Who Comment
Unknown file formatdmg pdf-plugin-242.dmg manage 385.6 K 2014-09-23 - 12:09 StephenNickerson Copy of PDF Browser Plugin 2.4.2 from www.schubert-it.com
Topic revision: r4 - 2014-10-01 - StephenNickerson
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback