These commands are used to control system logs, passwords, user name, browser configuration options, and display or configure a variety of other system information.
After initially logging onto the system, you should set Privileged Exec password. Remember to record it in a safe place. Use this command to control access to the Privileged Exec level from the Normal Exec level. Use the no form to remove the password.
Syntax
enable password [level level] {0 | 7} password
no enable password [level level]
- level level - Level 15 for Privileged Exec.
- {0 | 7} - 0 means plain password, 7 means encrypted password.
- password - password for this privilege level.
(Maximum length: 8 characters, and is case sensitive)
Default Setting
Command Mode
Global Configuration
Command Usage
Example
(config)#enable password level 15 0 admin
(config)#
Related Commands
Use this command to control logging of error messages. This command sends debug or error messages to a logging process. The no form disables the logging process.
Syntax
logging on
no logging on
Default Setting
None
Command Mode
Global Configuration
Command Usage
The logging process controls error messages to be sent to Simple Network Management Protocol (SNMP) trap receivers. You can use the logging history command to control the type of error messages that are stored in memory and sent to a specified SNMP trap receiver.
Example
(config)#logging on
(config)#
Related Commands
Use this command to limit syslog messages sent to the SNMP network management station based on severity. The no form returns the logging of syslog messages to the default level.
Syntax
logging history {flash | ram} level
no logging history {flash | ram}
- flash - Event history stored in flash memory (i.e., permanent memory).
- ram - Event history stored in temporary RAM (i.e., memory flushed on power reset).
- level - One of the level arguments listed in Table 1. Messages sent include the selected level up through level 0.
Level Argument Level Description Syslog Definition emergencies 0 System unusable LOG_EMERG alerts 1 Immediate action needed LOG_ALERT critical 2 Critical conditions LOG_CRIT errors 3 Error conditions LOG_ERR warnings 4 Warning conditions LOG_WARNING notifications 5 Normal but significant condition LOG_NOTICE informational 6 Informational messages only LOG_INFO debugging 7 Debugging messages LOG_DEBUG
Default Setting
Flash: errors (level 3 - 0)
RAM: warnings (level 4 - 0)
Command Mode
Global Configuration
Command Usage
Sending syslog messages to the SNMP network management station occurs when you enable syslog traps with the snmp enable traps command.
Example
(config)#logging history ram 0
(config)#
Related Commands
Use this command to clear messages from the log buffer.
Syntax
clear logging [flash | ram]
- flash - Event history stored in flash memory (i.e., permanent memory).
- ram - Event history stored in temporary RAM (i.e., memory flushed on power reset).
Default Setting
None
Command Mode
Privileged Exec
Example
#clear logging
#
Related Commands
Use this command to require user name authentication at login. Use the no
form to remove a user name.
Syntax
username name {access-level level | nopassword | {0 | 7} password password}
no username name
- name - The name of the user.
(Maximum length: 8 characters; maximum number of users: 16)
- access-level level - Specifies the user level.
The device has two predefined privilege levels: 0: Normal Exec, 15: Privileged Exec.- nopassword - No password is required for this user to log in.
- {0 | 7} - 0 means plain password, 7 means encrypted password.
- password password - The authentication password for the user.
(Maximum length: 8 characters, and is case sensitive)
Default Setting
Factory defaults for the user names and passwords are:
username access-level password guest
admin
0
15
guest
admin
Command Mode
Global Configuration
Command Usage
You can use an encrypted password to avoid exposing the password with the "show running-config" command. To create an encrypted password, you must use an appropriate encryption algorithm.
Example
(config)#username bob access-level 15
(config)#username bob password smith
(config)#
Use this command to specify or modify the host name for this device. Use the
no form to restore the default host name.
Syntax
hostname name
no hostname
name - The name of this host. (Maximum length: 255 characters)
Default Setting
Set by remote the management module, and is based on the switch position in the server chassis (i.e., first or second) and the service tag. For example, if the switch is the first module in the chassis, and the service tag is 1234123, then the hostname would be "switch2_1234123."
Command Mode
Global Configuration
Command Usage
The string specified by this command is inserted at the beginning of the command prompt. (Only the first 16 characters of the hostname are displayed in the command prompt.)
Example
(config)#hostname RD5
RD5(config)#
Use this command to enable jumbo frames through this device. Use the no
form to disable jumbo frames.
Syntax
jumbo frame
no jumbo frame
Default Setting
Disabled
Command Mode
Global Configuration
Command Usage
Example
(config)#jumbo frame
(config)#
Use this command to specify the TCP port number used by the Web browser interface.
Use the no form to use the default port.
Syntax
ip http port port-number
no ip http port
port-number - The TCP port to be used by the browser interface. (Range: 1-65535)
Default Setting
80
Command Mode
Global Configuration
Example
(config)#ip http port 769
(config)#
Related Commands
Use this command to allow this device to be monitored or configured from a
browser. Use the no form to disable this function.
Syntax
ip http server
no ip http server
Default Setting
Enabled
Command Mode
Global Configuration
Example
(config)#ip http server
(config)#
Related Commands
Use this command to display the configuration file stored in nonvolatile memory that is used to start up the system.
Default Setting
None
Command Mode
Privileged Exec
Example
#show startup-config
building startup-config, please wait.....
!
!
snmp-server community private rw
snmp-server community public ro
!
no snmp-server enable traps authentication
username guest access-level 0
username guest password guest
username admin access-level 15
username admin password admin
enable password level 0 0 guest
enable password level 15 0 admin
no logging on
!
vlan database
vlan 1 name DefaultVlan media ethernet state active
!
interface ethernet 1/1
switchport allowed vlan add 1 untagged
switchport native vlan 1.
.
.
.
interface vlan 1
ip address 10.1.0.1 255.255.255.0
!
no bridge 1 spanning-tree
!
line console
!
line vty
!
end
#
Related Commands
Use this command to display the configuration information currently in use.
Default Setting
None
Command Mode
Privileged Exec
Command Usage
Use this command in conjunction with the show startup-config command to compare the information in running memory to the information stored in nonvolatile memory.
Example
#show running-config
building running-config, please wait.....
!
!
snmp-server community private rw
snmp-server community public ro
!
username admin access-level 15
username admin password 7 21232f297a57a5a743894a0e4a801fc3
username guest access-level 0
username guest password 7 084e0343a0486ff05530df6c705c8bb4
enable password level 15 7 1b3231655cebb7a1f783eddf27d254ca
!
vlan database
vlan 1 name DefaultVlan media ethernet state active
vlan 2 name R&D media ethernet state active
!
!
interface ethernet 1/1
switchport allowed vlan add 1 untagged
switchport native vlan 1
.
.
.
interface vlan 1
ip address 10.1.0.1 255.255.255.0
!
no bridge 1 spanning-tree
!
line console
!
line vty
!
end
#
Related Commands
Use this command to display the logging configuration for system and event messages.
Syntax
show logging {flash | ram}
- flash - Event history stored in flash memory (i.e., permanent memory).
- ram - Event history stored in temporary RAM (i.e., memory flushed on power reset).
Default Setting
None
Command Mode
Privileged Exec
Example
#show logging
Syslog logging: Disable
History logging in FLASH: level errors
#config
Use this command to display system information.
Default Setting
None
Command Mode
Normal Exec, Privileged Exec
Example
#show system
System description: PowerEdge 1655MC Integrated Switch
System OID string: 1.3.6.1.4.1.674.10895.3
System information
System Up time: 0 days, 0 hours, 55 minutes, and 54.91 seconds
System Name : [NONE]
System Location : [NONE]
System Contact : [NONE]
MAC address : 00-00-e8-00-00-01
Web server : enable
Web server port : 80
POST result :
Loopback Testing UART Channel ................... PASS
Flash Memory Checksum Test....................... PASS
Testing the System SDRAM ........................ PASS
CPU Self Test ................................... PASS
MPC850 internal clock Timer and Interrupt TEST .. PASS
WatchDog Timer and Interrupt Test ............... PASS
PLX9054 Access Test ............................. PASS
BCM5633 Chip Test ............................... PASS
I2C R/W Test .................................... PASS
SERDES and PHY internal loopback Test............ PASS
#
Shows all active console and Telnet sessions, including user name, idle time, and IP address of Telnet client
Default Setting
None
Command Mode
Normal Exec, Privileged Exec
Example
#show users
Username accounts:
Username Privilege
-------- ---------
admin 15
guest 0
Online users:
Line Username Idle time (h:m:s) Remote IP addr.
----------- -------- ----------------- ---------------
0 console admin 28:04:39
* 1 vty 0 admin 0:00:00 10.1.0.19#
Use this command to display hardware and software version information for the system.
Default Setting
None
Command Mode
Normal Exec, Privileged Exec
Example
#show version
Unit1
Serial number :12
Service tag :
Hardware version :1
Number of ports :11
Main power status :up
Agent(master)
Unit id :1
Loader version :0.0.5.2
Boot rom version :1.0.7.7
Operation code version :0.3.0.36
#