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 Introduction
1.1 Product overview and rationale

The Pic language is a TROFF preprocessor for line drawing in UNIX environments.  WD-pic is a combination batch, WYSIWYG, direct-manipulation drawing program interfacing the Pic language.  The goal of WD-pic is to create Pic code which seems to have been created by a human while at the same time providing a convenient graphical interface in the X Windows environment.  WD-pic combines graphics and text building and editing of pictures, and produces pictures on a canvas as well as a Pic text file which represents the pictures.  It is chiefly intended for technical document illustration, such as flow charts, state diagrams and so on.  Knowledge of the Pic language is unnecessary although users who are familiar with Pic will be able to deploy the full functionality of WD-pic.

WD-pic was created to fulfill the need for a graphical user interface (GUI) for the Pic language in order to allow a convenient way to create complex technical drawings as well as providing direct-manipulation editing of the drawings.

1.2 Terminology and Basic Features
WD-pic operates on the following basic elements: box, circle, ellipse, arrow, line, spline, arc, move, and text (either associated with an element or standalone).  WD-pic provides ways for creating the elements as well as changing their characteristics.  In addition, WD-pic provides various editing functions through direct-manipulation of the picture and ways for editing the Pic code of the drawing.

Throughout this manual we will use the following terms:

 Closed Shape – one of box, circle, ellipse

 Linear Shape – one of line, arrow, spline
 Shape – all closed and linear shapes and arc
 Element – all shapes and move and text  (all elements are selectable except move)

 Insertion point – the point where the next element will be created

 Text File – the file containing the PIC code corresponding to the picture drawn on the canvas

 Click – unless otherwise specified, a left mouse click

The following text conventions will be used in the manual:

 Italics will be used to specify the name of programs and languages, the basic Pic elements, and attributes.

 Bold will be used to specify command names, switches, menu items, button names, and any text that must be entered exactly as it appears.

 <> will be used to specify symbols, letters and key names on the keyboard.

1.3 Summary of Display and Report Formats
The main screen is divided into 5 parts which are:  (Fig. 1)

1. The canvas – where the drawing is shown

2. The menu bar – located at the top of the window

3. The tool bar – located below the menu bar and provides direct access to some menu commands

4. The palette – located on the left-hand side of the window

5. The command line – located at the bottom of the window and provides direct access to the current line in the Pic code

The palette is divided into three parts:  (from top to bottom)

1. The Pic tokens buttons – allow the user to create basic Pic elements

2. The directions buttons – allow the user to set the current direction of insertion

3. The attributes buttons – allow the user to set the attributes of the currently selected object; these buttons are only available when applicable

Pop-up menus can be opened on the canvas.  A pop-up menu will include the attributes of the currently selected element (if there is a selected element) and the basic editing commands.

1.4 Outline of the Manual
Chapter 2, “Getting Started” guides you through your first steps in using WD-pic.   Here you will learn how to use WD-pic’s help and familiarize yourself with WD-pic by walking through a sample session.

Chapter 3, “Modes of operation” includes a complete description of all WD-pic’s  modes of operation, dialogues and various commands.

Chapter 4, “Advanced features” introduces features which are intended to be used by the more advanced user.

Chapter 5, “Command syntax and system options” contains a detailed specification of all the commands and system options.

Appendix A, “Special keyboard options” lists all the special keyboard options available.

Appendix B, “Pic language commands” lists all the Pic commands.

2.  Getting Started
2.1 Sign-on

The command line for running WD-pic is:


wdpic [pic_file]

pic_file is an optional parameter specifying the name of an existing Pic code file to load on startup.

A new window will be opened showing the WD-pic interface:

<PICTURE >

If the pic_file parameter was specified, the canvas will display the drawing which corresponds to the Pic code in the file.

2.2 Help mode

Getting help

There are four main ways to get help in WD-Pic through the Help menu, by pressing <F1>, by pressing <CTRL+F1> while working on an element, or by clicking the Help button in any dialog box.  

The Help menu contains the entry Help Topics which opens a window containing the table of contents, index, as well as a search feature.  The About WD-pic entry will open a window containing information about the developers of the program.  The <F1> key is a shortcut to the Help Topics window and is enabled only in the main window.

Pressing <CTRL+F1> while in the main window will open a help window containing information about the current element.  If there is no current element the Help Topics window will be opened.  

Clicking the Help button, available in any dialog box, will open a help window describing the options available in the dialog box and their effects on the drawing.

Navigating through the help

After opening a help window, you will probably want to find the specific place where the information you desire is located.  As always, there is more than one way to do this.

The help is composed of help pages, each page containing information on a specific topic. 

The simplest way to navigate through the help is through the Next, Previous, and Back buttons, located at the top of the window:

<PICTURE>

Help pages sometimes contain hyperlinks.  Hyperlinks come in two flavors,  the first appearing in blue color are links to other help pages containing related topics, clicking on them will bring you to the linked page (you can always go back by clicking the Back button).  The second flavor of hyperlinks appear in grey, these will usually be terms, and clicking on the link will open a pop-up window showing the definition of the term (to close the pop-up window, simply click anywhere in the help window).

<PICTURE>

The more advanced ways of navigating through the help are by using the help contents, the help index, and the search.  If you know the specific topic that you are looking for, then the help index is the place to go.  Simply type in the topic in the appropriate entry field and hopefully the topic list will jump right to the appropriate place:

<PICTURE>

If you know the general topic you are looking for and want to see all the related sub-topics you should look in the help contents.  The contents are displayed  in the form of a directory tree, and you access sub-topics by double clicking the icon next to the desired topic.  When you have found the desired topic, double click on the title to access its help page (or you can click the Open button).  Expanding and collapsing branches of the tree is done by double clicking the icon near the father of the branch.

<PICTURE>

If all you know about what you’re looking for is a word or a phrase, try using the search.  Type whatever you are looking for in the appropriate line and hit the Search button, a list of titles of help pages containing the word or phrase will appear.  Double click on any of them or choose a title and press the Display button, to open the selected help page.

2.3 Sample run

Start WD-pic by typing wdpic in the command line (for starters we will not use the optional parameter).  When WD-pic is up and running, you should see the following window:

<PICTURE>

Adding Basic Elements

Now it’s time for you to create your first WD-pic drawing.  From the palette on the left-hand side of the window, click on the Box button. A box should appear in the middle of the canvas:

<PICTURE>

Now you can add more elements to your drawing.  Start experimenting by adding several elements by clicking the Box, Circle, Ellipse, Arrow, Line, and Arc buttons. You might notice that each new element appears on the right of the previous element, and that all elements of the same type have the same size.

Naturally a complex drawing will require changing the direction in which the elements are arranged on the screen as well as the sizes and other attributes of the elements.

Saving, loading and clearing

You might want to start a new drawing now.  Since you have created a drawing, you might want to save it to a file first.  Click on the File menu and choose the Save as… entry.  You will see the following Save as… dialogue:

<PICTURE>

choose the directory in which you want to save the file and enter the name of the file to save to.  Now, let’s clear the canvas so that you can work on a new drawing.  From the File menu choose New, this will clear the canvas.  You might wonder what happened to the file that you saved earlier, you can load it any time you want by choosing the Load… entry from the File menu and choosing the file from the dialogue that opens.  

Usually if you’re working for a while, you will want to save the file several times.  You don’t have to enter the file name each time you save it, choosing the Save entry from the File menu will save the drawing to the last file name specified (if no file name was specified, the Save as… dialogue will automatically appear).    

Changing the direction of insertion

Try this: click on the ▼ button in the palette

<PICTURE>

now add a new box by clicking the Box button.  Notice that the new box appears below the previous element.  The four direction buttons (▲, ►, ▼ ,◄) are used to set the current direction of insertion.  
Creating branches

Although now you can change the direction in which new elements appears in the drawing, this in not sufficient to draw even the simplest drawings. For example, in order to be able to draw the following drawing:





you will have to go back to the first box (on the top-left corner) and then draw the arrow and box below it.

The way this drawing can be drawn in WD-pic is by clicking Box, Arrow, Box to create the first three elements:



Now click on the box on the left, this will select it.  A selected element appears with a double border:



A selected element has some importance when dealing with editing commands, but for now we will only use it as the current insertion point.  Now if you press ▼, Arrow, Box you will get the desired drawing.

Adding Text

Although a picture is worth a thousand words, sometimes a word here and there might be worth a thousand pictures.  Text in WD-pic can be one of two kinds: either associated with an element or not (standalone text).  Text that is associated with an element will appear inside the element if it is a closed shape or near the element if it is an open shape.  

To add text to an element, select the element to add to (note that by default, the last element that was added is the selected element).  Below the direction buttons, there is a section containing buttons for operating on the current element, called the attributes section.

<PICTURE>

To add the text, click on the Add Text button from the attributes section.  You will notice that a cursor is now blinking inside (or near) the element, so just type in the text that you want to appear.  After you have finished entering the text, either press the <Enter> key, click the Return focus to element button in the attribute section of the palette, or select a different element.  

To create standalone text, click the Text button in the palette.  You will see a cursor flashing on the screen at the place where the text will be inserted.  Type in the text and press the <Enter> key or the End Element button when you are done.

Changing attributes

All elements are created with default attributes, but often you will want to change an attribute in order to create different looking boxes, circles, etc.  For example, you don’t always want a box of the same size.  To change a attribute of the current element, click on the appropriate button in the attribute section of the palette.  A dialogue box will appear where you can change or set the attribute.  For example, this is the size attribute dialogue for a box:

<PICTURE>

For a complete list of all available attributes for the various elements, see Chapter 3 “Modes of operation”.  

Changing the insertion point

So far, the only drawings that you are enable to create are connected, but sometimes you might want to draw something that looks like this:



To create the above drawing, perform the following operations: click Box, add the text “Ellipse” to the box, and click on Arrow.  Now click on the canvas where you want the ellipse to appear, and click Ellipse. As simple as that.

A different way to move the insertion point, is by using the move element.  Click on the Move button to create one, and set its attributes (the location, whether relative to the current element or absolute in the drawing).

Using the keyboard

If you are familiar with the Pic language, you may find it easier sometimes to simply type in Pic code.  For the specific purpose, the command line was created.

<PICTURE>

Each keystroke (except for when typing in text) is automatically transferred to the command line.  The command is interpreted while typing and can be any Pic command (for a complete list of all Pic commands, see Appendix B).  For example, if you type the following string:  box width 0.6 height 0.3 the following effect will take place while typing:

1. After typing box, a box with of the default size will appear.

2. After typing box width 0.6, the box’s height will change to 0.6.

3. After typing box width 0.6 height 0.3, the box’s width will change to 0.3.

At any time, pressing the <Enter> key is equivalent to clicking the End Element button.  See Appendix A for a complete list of all the special keyboard options available.

If the string that you typed is not a valid Pic code line, a dialogue with a parsing error message will appear.  Click OK (or press <Enter>) to make it go away.

Manipulating existing elements

Sometimes you want to change the way an existing element looks.  In WD-pic you can do this by either changing the element’s attributes or by directly manipulating the element with the mouse.  Click on the edge of the element and drag the mouse to change the element’s size:

<PICTURE>

Click inside the element and drag the mouse to move it:

<PICTURE>

Editing

  WD-pic provides three basic editing options: copy, cut and paste.  Where: 

 copy – Copies the selected elements into the clipboard.

 cut – Copies the selected elements into the clipboard and deletes them from the drawing.

 paste – Pastes the contents of the clipboard into the drawing at the current insertion point.

To copy or cut elements, first select them by either dragging the mouse over the elements:

<PICTURE>

or by pressing down and holding the <CTRL> key and clicking the desired elements.  Once the elements are selected, choose the Copy (or Cut) entry from the Edit menu.  If you want to paste something, simply choose the Paste entry from the Edit menu.

Way-points

So far you were only able to create straight lines and arrows or simple arcs.  But sometimes you would like to create something that looks like this:




Of course you could create that by creating a box, a line, setting the insertion direction to down, and then creating another line, setting the insertion direction to right, creating another line, setting… 

Or you could just create one arrow that has way-points.  How do I do that, you want to know… Create the arrow and click on the Way-points button in the attribute section of the palette.  Now click on the canvas to create way-points.
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