switchport acceptable-frame-types
The commands described in this section are used to create Virtual Local Area Networks (VLAN) groups, add port members, specify how VLAN tagging is used, and enable automatic VLAN registration for the selected interface.
Use this command to enter VLAN database mode. All commands in this mode will take effect immediately.
Default Setting
None
Command Mode
Global Configuration
Command Usage
Example
(config)#vlan database
(config-vlan)#
Related Commands
Use this command to configure a VLAN. Use the no form to restore the default or delete a VLAN.
Syntax
vlan vlan-id [name vlan-name] media ethernet [state {suspend | active}]
no vlan vlan-id [name | state]
- vlan-id - ID of the configured VLAN. (Range: 1-4094, no leading zeroes)
- name - Keyword to be followed by the VLAN name.
- vlan-name - ASCII string from 1 to 32 characters.
- media ethernet - Ethernet media type.
- state - Keyword to be followed by the VLAN state.
- active - VLAN is operational.
- suspend - VLAN is suspended. Suspended VLANs do not pass packets.
Default Setting
By default only VLAN 1 exists and is active.
Command Mode
VLAN Database Configuration
Command Usage
Example
The following example adds a VLAN, using vlan-id 105 and name RD5. The VLAN is activated by default.
(config)#vlan database
(config-vlan)#vlan 105 name RD5 media ethernet
(config-vlan)#
Related Commands
Use this command to enter interface configuration mode for VLANs, and configure a physical interface.
Syntax
interface vlan vlan-id
vlan-id - ID of the configured VLAN. (Range: 1-4094, no leading zeroes)
Default Setting
None
Command Mode
Global Configuration
Example
The following example shows how to set the interface configuration mode to VLAN 1, and then assign an IP address to the VLAN:
(config)#interface vlan 1
(config-if)#ip address 192.168.1.254 255.255.255.0
(config-if)#
Related Commands
Use this command to enable ingress filtering for a port. Use the no form to restore the default.
Syntax
switchport ingress-filtering
no switchport ingress-filtering
Default Setting
Disabled
Command Mode
Interface Configuration (Ethernet, Port Channel)
Command Usage
Example
The following example shows how to set the interface to port 1 and then enable ingress filtering:
(config)#interface ethernet 1/1
(config-if)#switchport ingress-filtering
(config-if)#
Use this command to configure the acceptable frame types for a port. Use the no form to restore the default.
Syntax
switchport acceptable-frame-types {all | tagged}
no switchport acceptable-frame-types
- all - The port passes all frames, tagged or untagged.
- tagged - The port only passes tagged frames.
Default Setting
All frame types
Command Mode
Interface Configuration (Ethernet, Port Channel)
Command Usage
Example
The following example shows how to restrict the traffic passed on port 1 to tagged frames:
(config)#interface ethernet 1/1
(config-if)#switchport acceptable-frame-types tagged
(config-if)#
Related Commands
Use the switchport mode command to configure the VLAN membership mode for a port. Use the no form to restore the default.
Syntax
switchport mode {trunk | hybrid}
no switchport mode
- trunk - Specifies a port as an endpoint for a VLAN trunk. A trunk is a direct link between two switches, so the port transmits and receives tagged frames that identify the source VLAN.
- hybrid - Keyword that specifies a hybrid VLAN interface. The port may receive or transmit tagged or untagged frames. Any frames that are not tagged will be assigned to the default VLAN.
Default Setting
All ports are in hybrid mode with the PVID set to VLAN 1.
Command Mode
Interface Configuration (Ethernet, Port Channel)
Command Usage
This command and the switchport acceptable-frame-types command have the same effect.
Example
The following shows how to set the configuration mode to port 1, and then set the switchport mode to hybrid:
(config)#interface ethernet 1/1
(config-if)#switchport mode hybrid
(config-if)#
Related Commands
Use this command to configure untagged and tagged ports. Use the no form to restore the default.
Syntax
switchport allowed vlan {add vlan-id [tagged | untagged] | remove vlan-id}
no switchport allowed vlan
- add vlan-id - VLAN identifier to add.
- remove vlan-id - VLAN identifier to remove.
(Range: 1-4094, no leading zeroes)
Default Setting
Command Mode
Interface Configuration (Ethernet, Port Channel)
Example
The following example shows how to add VLANs 1, 2, 5 and 6 to the allowed list as tagged VLANs for port 1:
(config)#interface ethernet 1/1
(config-if)#switchport allowed vlan add 1 tagged
(config-if)#switchport allowed vlan add 2 tagged
(config-if)#switchport allowed vlan add 5 tagged
(config-if)#switchport allowed vlan add 6 tagged
(config-if)#
Use this command to configure the PVID (i.e., default VID) for a port. Use the no form to restore the default.
Syntax
switchport native vlan vlan-id
no switchport native vlan
vlan-id - Default VLAN ID for a port. (Range: 1-4094, no leading zeroes)
Default Setting
VLAN 1
Command Mode
Interface Configuration (Ethernet, Port Channel)
Command Usage
Example
The following example shows how to set the PVID for port 1 to VLAN 3:
(config)#interface ethernet 1/1
(config-if)#switchport native vlan 3
(config-if)#
Use this command to configure forbidden VLANs. Use the no form to remove the list of forbidden VLANs.
Syntax
switchport forbidden vlan {add vlan-id | remove vlan-id}
no switchport forbidden vlan
- add vlan-id - VLAN ID to add.
- Remove vlan-id - VLAN ID to remove.
(Range: 1-4094, no leading zeroes)
Default Setting
No VLANs are included in the forbidden list.
Command Mode
Interface Configuration (Ethernet, Port Channel)
Command Usage
This command prevents a port from being automatically added to the specified VLANs via GVRP.
Example
The following example shows how to prevent port 1 from being added to VLAN 3:
(config)#interface ethernet 1/1
(config-if)#switchport forbidden vlan add 3
(config-if)#
Use this command to show VLAN information.
Syntax
show vlan [id vlan-id | name vlan-name]
- name - Keyword to be followed by the VLAN ID.
- vlan-id - ID of the configured VLAN. (Range: 1-4094, no leading zeroes)
- name - Keyword to be followed by the VLAN name.
- vlan-name - ASCII string from 1 to 15 characters.
Default Setting
Shows all VLANs.
Command Mode
Normal Exec, Privileged Exec
Example
The following example shows how to display information for VLAN 1:
#show vlan id 1
VLAN Type Name Status Ports/Channel groups
---- ------- ---------------- --------- ---------------------------------------
1 Static DefaultVlan Active Eth1/ 1 Eth1/ 2 Eth1/ 3 Eth1/ 4 Eth1/ 5
Eth1/ 6 Eth1/ 7 Eth1/ 8 Eth1/ 9 Eth1/10
Eth1/11
#